Aus dem gleichen Grund hab ich am iMac 2009 seit 2 Jahren die externe Lösung und bin zufrieden ...

Hallo eimaeck!
Danke für die interessanten Infos.
Laut Wikipedia sollte allerdings auf allen Sierra-kompatiblen Geräten auch High Sierra lauffähig sein. Demnach müsste High Sierra sowohl auf 2009er als auch 2011er iMacs gehen.
----------