Problem gelöst mit KI

Das ist die Kurzversion der Lösung mit ChatGPT. Vorab haben wir DNS Server auf der Synology installiert.

DNS intern auf 192.168.178.XX bringen.
Herausfinden, dass Nextcloud cloud.XXXsynology.me noch nicht als vertrauenswürdige Domain kennt.
Einen Eintrag in config.php ergänzen.
Feststellen, dass Nextcloud hinter dem Reverse Proxy trotzdem glaubt, sie sei über HTTP angesprochen worden.
'overwriteprotocol' => 'https' ergänzen.
Fertig. ?

Der eigentliche technische Fehler war sogar ziemlich übersichtlich:

DNS → richtig
HTTPS → richtig
Reverse Proxy → richtig
Nextcloud → „Moment, diese Domain kenne ich nicht.“
Nextcloud danach → „Warum kommt ihr eigentlich über HTTP?“ ?